Wednesday, November 5, 2008

Slony-I

All today I've tried to make work Slony-I replication.
I installed default slony1-1.2.6 from oss openSUSE repository. PostgreSQL's version is 8.3.1 also from that repository.

But slony1-1.2.6 doesn't support postgresql-8.3.1.
So I downloaded slony-1.2.15. And now everything works fine.

For slony's configuring I use pgAdmin which can't create new replication and shows "Slony-I creation scripts not available; only joining possible" message on status bar.
To solve I set "Slony-I path" to "/usr/share/postgresql" in File --> Options --> "General" tab.
Powered by Blogger.